Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1939432 - perl-HTML-FormFu-MultiForm-1.03-12.fc35 FTBFS: Couldn't load Crypt::Cipher::AES: Can't locate Crypt/Cipher/AES.pm in @INC
Summary: perl-HTML-FormFu-MultiForm-1.03-12.fc35 FTBFS: Couldn't load Crypt::Cipher::A...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-HTML-FormFu-MultiForm
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F35FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-03-16 12:02 UTC by Petr Pisar
Modified: 2021-03-23 00:15 UTC (History)
2 users (show)

Fixed In Version: perl-HTML-FormFu-MultiForm-1.03-13.fc35 perl-HTML-FormFu-MultiForm-1.03-13.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-23 00:15:43 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Petr Pisar 2021-03-16 12:02:59 UTC
perl-HTML-FormFu-MultiForm-1.03-12.fc35 fails to build in Fedora 35 because the test fail like this:

t/00-report-prereqs.t ........................ ok
t/multiform-misc-file-client-side.t .......... skipped: CGI tmp_upload_dir functionality makes this unusable on modern versions
Couldn't load Crypt::Cipher::AES: Can't locate Crypt/Cipher/AES.pm in @INC (you may need to install the Crypt::Cipher::AES module) (@INC contains: /builddir/build/BUILD/HTML-FormFu-MultiForm-1.03/blib/lib /builddir/build/BUILD/HTML-FormFu-MultiForm-1.03/blib/arch /usr/local/lib64/perl5/5.32 /usr/local/share/perl5/5.32 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 465) line 1.
 at /builddir/build/BUILD/HTML-FormFu-MultiForm-1.03/blib/lib/HTML/FormFu/MultiForm.pm line 464.
# Looks like your test exited with 2 just after 3.
t/multiform-misc/accessors.t ................. 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 3/6 subtests

A difference between passing and failing build root is at <https://koschei.fedoraproject.org/build/9825761>. An upgrade of perl-Crypt-CBC from 2.33-30.fc34 to 3.01-1.fc34 looks suspicious.

Comment 1 Petr Pisar 2021-03-16 14:48:37 UTC
This is triggered by upgrading perl-Crypt-CBC to 3.01 and caused by perl-Crypt-CBC not run-requiring perl(Crypt::AES):

$ perl -MCrypt::CBC -e 'Crypt::CBC->new(-key => 1)'
Couldn't load Crypt::Cipher::AES: Can't locate Crypt/Cipher/AES.pm in @INC (you may need to install the Crypt::Cipher::AES module) (@INC contains: /usr/local/lib64/perl5/5.32 /usr/local/share/perl5/5.32 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at (eval 5) line 1.
 at -e line 1.

Crypt::CBC::new() documentation reads:

         -cipher         The cipher algorithm (defaults to Crypt::Cipher:AES), or
                         a previously created cipher object reference. For 
                         convenience, you may omit the initial "Crypt::" part
                         of the classname and use the basename, e.g. "Blowfish"
                         instead of "Crypt::Blowfish".

perl-Crypt-CBC does not require perl(Crypt::AES) on purpose (bug #1087536 comment #3). We had this situation already with Crypt::DES. I will adjust perl-HTML-FormFu-MultiForm.

Comment 2 Fedora Update System 2021-03-16 15:28:47 UTC
FEDORA-2021-3e5f135703 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3e5f135703

Comment 3 Fedora Update System 2021-03-16 23:30:17 UTC
FEDORA-2021-3e5f135703 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-3e5f135703`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-3e5f135703

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-03-23 00:15:43 UTC
FEDORA-2021-3e5f135703 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.