Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1949503 - F35FailsToInstall: r2cutter
Summary: F35FailsToInstall: r2cutter
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: r2cutter
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Ambroz
QA Contact:
URL:
Whiteboard:
: 1955349 (view as bug list)
Depends On:
Blocks: F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-04-14 12:53 UTC by Miro Hrončok
Modified: 2021-04-29 22:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-29 12:39:53 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2021-04-14 12:53:31 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (r2cutter) Fails To Install in Fedora 35:

can't install r2cutter:
  - nothing provides libr_anal.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_asm.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_bin.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_bp.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_config.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_cons.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_core.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_crypto.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_debug.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_egg.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_flag.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_fs.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_hash.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_io.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_parse.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_reg.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_search.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_syscall.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  - nothing provides libr_util.so.5.1.1()(64bit) needed by r2cutter-0.1.1-4.fc35.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Henrik Nordström 2021-04-14 23:20:44 UTC
Need update to match radare2 API changes. But not sure how to proceed with the name change.

Comment 2 Miro Hrončok 2021-04-21 19:08:15 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Michal Ambroz 2021-04-25 15:35:23 UTC
Hello,
package is going to be retired. The new package iaito is already pushed to updates to obsolete and retire the r2cutter.
Mik

Comment 4 Michal Ambroz 2021-04-29 12:39:53 UTC
package retired - was renamed to iaito with the relevant Obsoletes/Provides

Comment 5 Miro Hrončok 2021-04-29 22:14:45 UTC
*** Bug 1955349 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.