Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1950304 - python-octave-kernel: FTBFS with Python 3.10
Summary: python-octave-kernel: FTBFS with Python 3.10
Alias: None
Product: Fedora
Classification: Fedora
Component: python-octave-kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Elliott Sales de Andrade
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
Reported: 2021-04-16 11:09 UTC by Tomáš Hrnčiar
Modified: 2021-06-13 04:04 UTC (History)
2 users (show)

Fixed In Version: python-octave-kernel-0.32.0-4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2021-06-13 04:04:15 UTC
Type: Bug

Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-04-16 11:09:54 UTC
Description of problem:
Package python-octave-kernel fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):

Steps to Reproduce:
koji build --scratch f35 python-octave-kernel-0.32.0-3.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:

Comment 1 Elliott Sales de Andrade 2021-04-17 03:20:14 UTC
This is neither broken on Rawhide nor on koschei.

Comment 2 Tomáš Hrnčiar 2021-04-20 09:34:12 UTC
I've tried another rawhide scratch build and it failed again.

FAIL: test_completion (__main__.OctaveKernelTests) (text='acos')
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/jupyter_kernel_test/", line 132, in test_completion
    validate_message(reply, 'complete_reply', msg_id)
  File "/usr/lib/python3.9/site-packages/jupyter_kernel_test/", line 170, in validate_message
    nt.assert_equal(msg['msg_type'], msg_type)
AssertionError: 'kernel_info_reply' != 'complete_reply'
- kernel_info_reply
+ complete_reply
Ran 12 tests in 4.125s
FAILED (failures=1, skipped=8)

We are getting the same error also in Python 3.10. COPR.

Comment 3 Miro Hrončok 2021-06-04 20:13:37 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.

The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.


See also

If you have general questions about the rebuild, please use this mailing list thread:

Comment 4 Miro Hrončok 2021-06-07 22:58:23 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 5 Elliott Sales de Andrade 2021-06-13 04:04:15 UTC
Seems to have built fine.

Note You need to log in before you can comment on or make changes to this bug.