Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1981749 - copr-keygen fails to build with Sphinx 4.0.2
Summary: copr-keygen fails to build with Sphinx 4.0.2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: copr-keygen
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Copr Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1975260
Blocks: 1973718 1987412
TreeView+ depends on / blocked
 
Reported: 2021-07-13 10:05 UTC by Karolina Surma
Modified: 2021-08-23 07:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-23 07:29:10 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Karolina Surma 2021-07-13 10:05:04 UTC
copr-keygen fails to build with Sphinx 4.0.2 in Fedora 35 (currently Rawhide).

+ make -C docs -j2 html
make: Entering directory '/builddir/build/BUILD/copr-keygen-1.80/docs'
sphinx-build-3 -b html -d _build/doctrees   . _build/html
Running Sphinx v4.0.2
Extension error:
Could not import extension sphinxcontrib.autohttp.flask (exception: cannot import name 'force_decode' from 'sphinx.util' (/usr/lib/python3.10/site-packages/sphinx/util/__init__.py))
make: *** [Makefile:45: html] Error 2

For the logs from testing build attempts, see:
https://copr.fedorainfracloud.org/coprs/ksurma/pygments-2.9.0/package/copr-keygen/

You can test you package using Koji scratch build
koji build --scratch <srpm>

Let us know here if you have any questions. Thank you!

Note: this is a caused by a reported problem with python-sphinxcontrib-httpdomain; this ticket is created for better impact visibility.

Comment 1 Miroslav Suchý 2021-07-13 10:48:53 UTC
We are watching bug 1975260. In case it will not be fixed soon, we will comment out the relevant line in spec and rebuild it. But this is leaf package, so I would like to wait few weeks and hope that bug 1975260 gets fix soon.

Comment 2 Karolina Surma 2021-08-06 11:28:58 UTC
After Sphinx' update to 4.1.2 copr-keygen started to build successfully - `force_decode` removal was reverted for now (build logs: https://copr.fedorainfracloud.org/coprs/ksurma/pygments-2.9.0/build/2365175/)

Comment 3 Ben Cotton 2021-08-10 13:13:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 4 Miroslav Suchý 2021-08-23 07:29:10 UTC
I verified that it works now.


Note You need to log in before you can comment on or make changes to this bug.