Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2007829 - Not able to mount LUKS encrypted partition when user logs in
Summary: Not able to mount LUKS encrypted partition when user logs in
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pam_mount
Version: 35
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-25 09:07 UTC by Matthias
Modified: 2021-11-10 02:53 UTC (History)
4 users (show)

Fixed In Version: pam_mount-2.18-1.fc35
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-10 02:53:45 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Matthias 2021-09-25 09:07:14 UTC
Description of problem:
I use pam_mount to mount an LUKS encrypted partition at the time a user logs in.

1. Upgrade from F34 to F35 fails because of pam_mount and its dependencies -> can only upgrade with --allowerasing
2. Once upgraded it is not possible to install pam_mount again, therefore not able to login to user account that uses data on encrypted partition

Issue as far as I can tell:
- There is no pam_mount for F35. The only build failed.
- The version for F34 cannot be installed because it requires cryptsetup-luks-libs. In F34 cryptsetup-luks-libs is provided by the cryptsetup-libs rpm. In F35 the cryptsetup-libs rpm does not contain cryptsetup-luks-libs.

Version-Release number of selected component (if applicable):
F35 versions:
pam_mount: https://koji.fedoraproject.org/koji/buildinfo?buildID=1794338
cryptsetup-libs: https://koji.fedoraproject.org/koji/rpminfo?rpmID=27842441

F34 versions:
cryptsetup-libs: https://koji.fedoraproject.org/koji/rpminfo?rpmID=26288131

How reproducible:
Always

Actual results:
Cannot login to user account with /home on LUKS encrypted partition

Expected results:
Above works as in F34

Comment 1 Fedora Update System 2021-11-01 12:02:48 UTC
FEDORA-2021-7c06731a3b has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-7c06731a3b

Comment 2 Fedora Update System 2021-11-02 02:06:06 UTC
FEDORA-2021-7c06731a3b has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-7c06731a3b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-7c06731a3b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Matthias 2021-11-02 09:36:38 UTC
I installed pam_mount. However, it does not open the LUKS encrypted partition. (cryptsetup-libs rpm for F35 has still no cryptsetup-luks-libs)

Comment 4 Fedora Update System 2021-11-10 02:53:45 UTC
FEDORA-2021-7c06731a3b has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.