Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 207846 (finance-YahooQuote) - Review Request: perl-Finance-YahooQuote - Perl interface to get stock quotes from Yahoo! Finance
Summary: Review Request: perl-Finance-YahooQuote - Perl interface to get stock quotes ...
Alias: finance-YahooQuote
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Christopher Stone
QA Contact: Fedora Package Reviews List
Depends On: 197841
TreeView+ depends on / blocked
Reported: 2006-09-24 16:35 UTC by Warren Togami
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-12-23 18:08:02 UTC
Type: ---

Attachments (Terms of Use)

Description Warren Togami 2006-09-24 16:35:53 UTC
Description: Perl interface to get stock quotes from Yahoo! Finance

Comment 1 Christopher Stone 2006-09-24 18:40:12 UTC
BuildRequires needs perl(HTTP::Request::Common) in order for mock to run %check.

Comment 2 Warren Togami 2006-09-24 21:24:12 UTC
Oops, we need to turn off the %check because a package build must not require
network access.  Thanks.

Comment 3 Christopher Stone 2006-09-25 22:12:57 UTC
Warren:  I tried to build this under mock with %check enabled and a BR of
perl(HTTP::Request::Common).  This also results in a failure and warnings
mentioned in the build log of missing packages.  By using a BR of
perl(HTTP::Request), this fixes the problem.

perl(HTTP::Request) needs to be added to the BR in order for %check to function
and should be added even though it is not used for official builds.  A developer
who enables the %check section would not automatically know this otherwise.

The build log also indicates that rpm is adding a Requires of
perl(HTTP::Request::Common), however, when I tried using this for a BR, it fails
and the following warnings are shown:
Warning: prerequisite HTML::Parser 2.2 not found.
Warning: prerequisite HTTP::Request 1.23 not found.
Warning: prerequisite LWP::UserAgent 1.62 not found.

These packages do not show up as being required by rpm.  Therefore, I think a
"Requires: perl(HTTP::Request)" also needs to be added to the spec file.  Please
add this unless you can show that it is not required.

==== Review Checklist ====
- rpmlint output clean
- package named according to package naming guidelines
- filename matches spec's %{name}
- package meets packaging guidelines
- package licensed with opensource compatible license
- license in spec matches actual license
- license included in %doc
- spec written in American english
- spec file legible
- sources match upstream
844d26ef02f16216840aac5815a6a6a7  Finance-YahooQuote-0.21.tar.gz
- package successfully compiles and builds on FC5 x86_64
- package does not contain locales
- package does not contain shared libraries/static libraries/pkgconfig files or
any other files required for a devel subpackage
- package is not relocatable
- package does not contain duplicate files in %files
- permissions on files set properly
- package contains proper %clean section
- macro usage is consistent
- package contains code
- no large documentation files
- files in %doc do not affect runtime
- no need for .desktop files

=== MUST ===
- Please address concerns I have about BuildRequires and Requires issues I
mention above.

Comment 4 Christopher Stone 2006-09-25 22:57:43 UTC
I've looked into this problem a bit more and the root.log is showing that using
perl(HTTP::Request::Common) brings in the mod_perl package instead of the
perl-libwww-perl package.

Should mod_perl be Providing perl(HTTP::Request::Common)?

Comment 5 Christopher Stone 2006-09-27 22:53:26 UTC
Ok, I found the problem, see bug #208348

Comment 6 Christopher Stone 2006-12-22 17:36:03 UTC
This package is currently approved for FC7+ only.

mod_perl-2.0.3-3 must be built for FC6/FC5 before branching to those releases.

See bug #197841 for more information.

Comment 7 Warren Togami 2006-12-23 18:08:02 UTC
Imported and branched on FC5 and FC6.  (mod_perl while problematic was a
non-issue for this.)

Note You need to log in before you can comment on or make changes to this bug.