Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 449426 - FTBFS vtk-5.0.4-21.fc9
Summary: FTBFS vtk-5.0.4-21.fc9
Keywords:
Status: CLOSED DUPLICATE of bug 434528
Alias: None
Product: Fedora
Classification: Fedora
Component: vtk
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Depends On:
Blocks: FTBFS
TreeView+ depends on / blocked
 
Reported: 2008-06-02 16:46 UTC by FTBFS
Modified: 2008-07-03 15:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-03 15:51:03 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
root.log.bz2 (deleted)
2008-06-02 16:46 UTC, FTBFS
no flags Details
build.log.bz2 (deleted)
2008-06-02 16:46 UTC, FTBFS
no flags Details
root.log.bz2 (deleted)
2008-06-02 16:46 UTC, FTBFS
no flags Details
build.log.bz2 (deleted)
2008-06-02 16:47 UTC, FTBFS
no flags Details

Description FTBFS 2008-06-02 16:46:04 UTC
vtk-5.0.4-21.fc9.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.

Comment 1 FTBFS 2008-06-02 16:46:29 UTC
Created attachment 307455 [details]
root.log.bz2

root.log for i386

Comment 2 FTBFS 2008-06-02 16:46:41 UTC
Created attachment 307456 [details]
build.log.bz2

build.log for i386

Comment 3 FTBFS 2008-06-02 16:46:53 UTC
Created attachment 307457 [details]
root.log.bz2

root.log for x86_64

Comment 4 FTBFS 2008-06-02 16:47:01 UTC
Created attachment 307458 [details]
build.log.bz2

build.log for x86_64

Comment 5 Orion Poplawski 2008-06-02 20:17:02 UTC
Axel -

 How does this look as a fix:

diff -u -r1.10 vtk.spec
--- vtk.spec    21 May 2008 20:20:18 -0000      1.10
+++ vtk.spec    2 Jun 2008 20:11:27 -0000
@@ -1,6 +1,7 @@
 %bcond_without OSMesa
 %bcond_with qt4
 %bcond_with java
+%bcond_with check

 %{!?python_sitearch:%global python_sitearch %(%{__python} -c "from
distutils.sysconfig import get_python_lib; print get_python_lib(1)")}

@@ -288,8 +289,12 @@
 # Add exec bits to shared libs ...
 chmod 0755 %{buildroot}%{_libdir}/vtk-5.0/CMake/*.so

-%check || :
-#LD_LIBARARY_PATH=`pwd`/bin ctest -V
+%if %{with check}
+%check
+#Most of these fail due to no DISPLAY, but someone might want to run them by hand
+export LD_LIBRARY_PATH=`pwd`/bin
+ctest
+%endif

 %clean
 rm -rf %{buildroot}


Comment 6 Matt Domsch 2008-07-03 15:51:03 UTC
patch included in this report

*** This bug has been marked as a duplicate of 434528 ***


Note You need to log in before you can comment on or make changes to this bug.