Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 449506 - FTBFS f-spot-0.4.3.1-1.fc10
Summary: FTBFS f-spot-0.4.3.1-1.fc10
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: f-spot
Version: rawhide
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Nigel Jones
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Depends On: 455158
Blocks: FTBFS
TreeView+ depends on / blocked
 
Reported: 2008-06-02 20:02 UTC by FTBFS
Modified: 2008-07-14 11:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 11:14:34 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
root.log.bz2 (deleted)
2008-06-02 20:03 UTC, FTBFS
no flags Details
build.log.bz2 (deleted)
2008-06-02 20:03 UTC, FTBFS
no flags Details

Description FTBFS 2008-06-02 20:02:57 UTC
f-spot-0.4.3.1-1.fc10.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.

Comment 1 FTBFS 2008-06-02 20:03:23 UTC
Created attachment 307705 [details]
root.log.bz2

root.log for x86_64

Comment 2 FTBFS 2008-06-02 20:03:35 UTC
Created attachment 307706 [details]
build.log.bz2

build.log for x86_64

Comment 3 Alex Lancaster 2008-07-04 11:22:01 UTC
Somebody should really look at this soon.  They'll be a major stink from users
if f-spot gets removed because it failed to build from source.

Comment 4 Matt Domsch 2008-07-05 04:35:50 UTC
Alex, f-spot is orphaned, it needs an owner to that will provide care and feeding.

Comment 5 Alex Lancaster 2008-07-05 04:45:20 UTC
(In reply to comment #4)
> Alex, f-spot is orphaned, it needs an owner to that will provide care and feeding.

I know, I was hoping somebody would step up to avoid it disappearing.  I'll
mention it on fedora-devel-list to see if there is some traction  Meanwhile, I'm
working on getting it to build to keep it alive until there is a more permanent
maintainer. 

Meanwhile it won't rebuild because of major issues with various mono issues
caused by the premature pushing of gnome-sharp-2.20 into rawhide which moved a
lot of functionality into a new package: gnome-desktop-sharp which hasn't yet
been packaged:

http://www.redhat.com/archives/fedora-devel-list/2008-July/msg00198.html

For this reason, I think various mono packages should be given a little extra
time to fix their packages to build from source before being pulled because of
the collateral damage caused by this premature update.

Comment 6 Nigel Jones 2008-07-06 01:40:36 UTC
Okie Dokie, going to try and look into this now.

Comment 7 Alex Lancaster 2008-07-06 01:55:18 UTC
gnome-desktop-sharp issue is now resolved, but as I mentioned on the
fedora-devel-list thread it now currently fails to build because of an actual
compilation error, see:

http://koji.fedoraproject.org/koji/taskinfo?taskID=698211
http://koji.fedoraproject.org/koji/getfile?taskID=698211&name=build.log

specifically:

error CS0136: A local variable named `result' cannot be declared in this scope
because it would give a different meaning to `result', which is already used in
a `method argument' scope to denote something else
generated/VolumeAdapter.cs(152,72): (Location of the symbol related to previous
error)
error CS0136: A local variable named `result' cannot be declared in this scope
because it would give a different meaning to `result', which is already used in
a `method argument' scope to denote something else
generated/VolumeAdapter.cs(183,72): (Location of the symbol related to previous
error)
Compilation failed: 12 error(s), 0 warnings


Comment 8 Nigel Jones 2008-07-06 09:18:14 UTC
Okay, so it seems progress is possible, I'm onto a new problem,

generated/DataInputStream.cs(157,42): error CS1502: The best overloaded method match for 
`GLib.DataInputStream.g_data_input_stream_read_until(System.IntPtr, System.IntPtr, out 
System.UIntPtr, System.IntPtr, out System.IntPtr)' has some invalid arguments
generated/DataInputStream.cs(151,45): (Location of the symbol related to previous error)
generated/DataInputStream.cs(157,42): error CS1620: Argument `3' must be passed with the `out' 
keyword
generated/DataInputStream.cs(160,42): error CS0165: Use of unassigned local variable `native_length'
generated/DataInputStream.cs(160,25): error CS0103: The name `length' does not exist in the current 
context
Compilation failed: 4 error(s), 0 warnings

Basically changing all instances of: <parameter type="GAsyncResult*" name="result" /> to <parameter 
type="GAsyncResult*" name="res" /> fixed it, will build a new RPM with this soon.

Comment 9 Alex Lancaster 2008-07-06 10:29:36 UTC
That sounds like good news.  Can you pass this information to upstream f-spot? 
I wonder why the f-spot devs aren't seeing the same problem (since they
presumably compiled it before they released 0.4.4)?  Perhaps they are using a
different mono?

Comment 10 Matt Domsch 2008-07-08 04:34:45 UTC
builds as of 2008-07-03, version 0.4.3.1-2.fc10.

Comment 11 Alex Lancaster 2008-07-08 07:31:20 UTC
(In reply to comment #10)
> builds as of 2008-07-03, version 0.4.3.1-2.fc10.

But doesn't build against new gnome-sharp and gnome-desktop-sharp, and is
currently broken in rawhide re-opening.  Nigel Jones is working on this.  But it
definitely shouldn't be removed.

Comment 12 Alex Lancaster 2008-07-11 11:49:22 UTC
(In reply to comment #8)
> Okay, so it seems progress is possible, I'm onto a new problem,

[...]

> Basically changing all instances of: <parameter type="GAsyncResult*"
name="result" /> to <parameter 
> type="GAsyncResult*" name="res" /> fixed it, will build a new RPM with this soon.

Ping?  Any progress on that "new RPM". This is still causing broken deps in
rawhide (and is blocking the FTBFS):

Broken deps for i386
----------------------------------------------------------
	f-spot-0.4.3.1-2.fc10.i386 requires mono(gnome-sharp) = 0:2.16.0.0
	f-spot-0.4.3.1-2.fc10.i386 requires mono(gnome-vfs-sharp) = 0:2.16.0.0
	f-spot-0.4.3.1-2.fc10.i386 requires mono(gtkhtml-sharp) = 0:2.16.0.0
	f-spot-0.4.3.1-2.fc10.i386 requires mono(gconf-sharp) = 0:2.16.0.0




Comment 13 Nigel Jones 2008-07-11 12:24:16 UTC
Yeah, I'm still working on it, no overall progress, I've been told that gtk-
sharp 2.12.1 fixes the gio problems, but I really need to re-setup my Rawhide 
environment again hope to get this sorted for this coming week.

I'll update again soon.

Comment 14 Nigel Jones 2008-07-13 04:48:41 UTC
Okay, the gio stuff built no problem with gtk-sharp2 2.12.1 so things are 
looking up, I'll file a bug against gtk-sharp2 when I can confirm that 
everything else will build okay.

The good news is that it seems that 2.12.0->2.12.1 doesn't require a rebuild of 
everything.

Comment 15 Nigel Jones 2008-07-13 08:09:21 UTC
Another update, I managed to get 0.4.4 to BFS, just need gtk-sharp2 > 2.12.1 
(Bug #455158), a patch I need to compose, and we'll be right!

Comment 16 Alex Lancaster 2008-07-14 05:48:57 UTC
Looks like gtk-sharp2-2.12.1-1.fc10 has been successfully rebuilt now:

http://koji.fedoraproject.org/koji/buildinfo?buildID=55855

Comment 17 Nigel Jones 2008-07-14 06:34:54 UTC
(In reply to comment #16)
> Looks like gtk-sharp2-2.12.1-1.fc10 has been successfully rebuilt now:
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=55855

Yeah, I got the e-mail this morning, just need to fix up the patches and commit 
it.

Comment 18 Alex Lancaster 2008-07-14 10:18:10 UTC
I just built gtk-sharp2-2.12.1-2.fc10 against the new RPM to fix the
Requires/Provides problem:

http://koji.fedoraproject.org/koji/rpminfo?rpmID=661287

Looks like the Provides/Requires are now OK:

http://koji.fedoraproject.org/koji/rpminfo?rpmID=661287

mono(atk-sharp) = 2.12.0.0
mono(gdk-sharp) = 2.12.0.0
mono(glade-sharp) = 2.12.0.0
mono(glib-sharp) = 2.12.0.0
mono(gtk-dotnet) = 2.12.0.0
mono(gtk-sharp) = 2.12.0.0
mono(pango-sharp) = 2.12.0.0

Comment 19 Nigel Jones 2008-07-14 11:14:34 UTC
Built f-spot-0.4.4-4.fc10 successfully for all architectures.


Note You need to log in before you can comment on or make changes to this bug.