Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 516041 - file descriptor out of range in select
Summary: file descriptor out of range in select
Keywords:
Status: CLOSED DUPLICATE of bug 499854
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:40c14cc190179f2d8...
: 516298 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-06 14:14 UTC by Clyde E. Kunkel
Modified: 2009-08-08 00:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-06 14:37:09 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (deleted)
2009-08-06 14:14 UTC, Clyde E. Kunkel
no flags Details
Attached traceback automatically from anaconda. (deleted)
2009-08-07 14:45 UTC, Clyde E. Kunkel
no flags Details

Description Clyde E. Kunkel 2009-08-06 14:14:07 UTC
The following was filed automatically by anaconda:
anaconda 12.7 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/subprocess.py", line 1152, in _communicate
    rlist, wlist, xlist = select.select(read_set, write_set, [])
  File "/usr/lib/python2.6/subprocess.py", line 663, in communicate
    return self._communicate(input)
  File "/usr/lib/anaconda/iutil.py", line 163, in execWithCapture
    (outStr, errStr) = proc.communicate()
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 328, in lvs
    stderr="/dev/tty5")
  File "/usr/lib/anaconda/storage/devices.py", line 2114, in status
    lvstatus = lvm.lvs(self.vg.name)
  File "/usr/lib/anaconda/storage/devices.py", line 2144, in teardown
    log_method_call(self, self.name, status=self.status)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1761, in teardownAll
    device.teardown(recursive=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1751, in populate
    self.teardownAll()
  File "/usr/lib/anaconda/storage/__init__.py", line 291, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 92, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 548, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 981, in <module>
    anaconda.intf.run(anaconda)
ValueError: filedescriptor out of range in select()

Comment 1 Clyde E. Kunkel 2009-08-06 14:14:16 UTC
Created attachment 356518 [details]
Attached traceback automatically from anaconda.

Comment 2 Chris Lumens 2009-08-06 14:37:09 UTC

*** This bug has been marked as a duplicate of bug 4 ***

Comment 3 Andy Lindeberg 2009-08-06 14:51:09 UTC
Not so much...

*** This bug has been marked as a duplicate of bug 499854 ***

Comment 4 Clyde E. Kunkel 2009-08-06 14:57:39 UTC
This was encountered when trying rawhide of 20090806 and the x server failed however allowing a text mode install.  When the traceback occurred, selecting save and bugzilla worked as opposed to failing during a gui session (bz https://bugzilla.redhat.com/show_bug.cgi?id=497240  anaconda loops endlessly when trying to save traceback.)

I probably should have killed the submission...sorry for the noise.

BTW VNC install seems to be ok (except for 499854).

Comment 5 Clyde E. Kunkel 2009-08-07 14:45:31 UTC
Created attachment 356663 [details]
Attached traceback automatically from anaconda.

Comment 6 Clyde E. Kunkel 2009-08-07 14:51:27 UTC
and again with anaconda 12.10.

Comment 7 David Lehman 2009-08-08 00:22:31 UTC
*** Bug 516298 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.