Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1450122 (qt5-qtmidi) - Review Request: qtmidi - Qt 5 Multimedia Library
Summary: Review Request: qtmidi - Qt 5 Multimedia Library
Alias: qt5-qtmidi
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: FE-DEADREVIEW qt-reviews
TreeView+ depends on / blocked
Reported: 2017-05-11 15:11 UTC by greg.hellings
Modified: 2020-08-10 00:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2020-08-10 00:56:44 UTC
Type: ---

Attachments (Terms of Use)

Description greg.hellings 2017-05-11 15:11:12 UTC
Spec URL:
Description: Qt is a set of libraries for developing applications.

This package contains an plugin to support MIDI input and output devices.
Fedora Account System Username:greghellings

Comment 1 Rex Dieter 2017-06-20 15:34:42 UTC
I think this should be named just qtmidi, we only use qt5- prefix on core modules released by (to ensure parallel-installability mostly)

Comment 2 Raphael Groner 2017-07-11 18:34:07 UTC
Isn't that guideline in conflict with how we commonly do it for qt5 addons to use -qt5 as a suffix instead?

My vote goes for the package name qtmidi-qt5.

Comment 3 Michael Schwendt 2017-08-12 14:52:43 UTC
There is absolutely no reason for the src.rpm %name to be qt5-qtmidi instead of qtmidi. Upstream name is "qtmidi", and that ought to be the %name for this package.

The naming guidelines are also clear about how to name the binary packages: %{parent}-%{child}, and since there are multiple versions of Qt in the distribution, an extension lib for Qt5 makes %parent "qt5".


Regardless of the naming stuff, the package ought to be fixed. Please consider pointing the fedora-review tool at this ticket:

  fedora-review -b 1450122

That tool is not only for reviewers. Packagers ought to be familiar with it, too.


Some findings based on skimming over the spec file:

> Summary:        Qt 5 Multimedia Library

Ambiguous. Better:

  Platform independent MIDI module for Qt 5.

> License:        GPL-3.0

This has never been one of the license tags used by Fedora:

> %description
> Qt is a set of libraries for developing applications.

Simplified so much, it isn't helpful. Interestingly, the %description of qt5-qtbase is very simple, too.

>  This package contains an plugin to support MIDI input and output devices.

... a plugin ...

> %package devel
> Summary:        Qt Development Kit

Not true. Inaccurate.

> Group:          Development/Libraries/X11

Unusual, and the "Group:" tag should not be set anymore for years:

> Requires:       %{name} = %{version}

> Provides:       libQt5Midi-devel = %{version}
> Obsoletes:      libQt5Midi-devel < %{version}

> Provides:       libQt5Midi-private-headers-devel = %{version}
> Obsoletes:      libQt5Midi-private-headers-devel < %{version}

What other distribution do these try to cover? Debian? Come on, these would be of very limited use to package users and would only cause Repo/RPM metadata bloat.

> %files private-headers-devel
> %license LICENSE.GPLv3
> %doc

Superfluous duplication of %license and %doc files, since package depends on -devel.

Comment 4 Raphael Groner 2017-08-12 23:39:13 UTC
Ping? Reporter, are you still interested in this package?

Comment 5 greg.hellings 2017-08-16 22:35:47 UTC
Yes, I'm still interested. Apologies - I was on vacation for the summer and then the Fedora 26 upgrade broke my system pretty nasty. I will update this PR.

Many of the oddities are a result of this Spec file's pedigree. Upstream provides a build of this package for Fedora/SuSE/Ubuntu and others from the OpenSuSE Build Service. I picked this up from there and brought it along for this PR. I thought I had nipped most of the problems, but clearly not!

Comment 6 greg.hellings 2017-09-25 19:44:21 UTC
OK, I've renamed the main specfile and SRPM to qtmidi. I've also tried to eliminate the cruft from the metadata and the build process, where possible. I'm generating out qt5-qtmidi binary packages. And I tried to make better sense out of the summaries and descriptions based off what upstream's spec file had already said about itself.

Spec file:

Comment 7 Orcan Ogetbil 2017-10-18 04:36:36 UTC
Package doesn't build in rawhide:

  + tar xaf /builddir/build/SOURCES/archive.tar.bz2
  + '[' 0 -ne 0 ']'
  + mv 'qtmidi-v0.1-*' qtmidi-0.1
  mv: cannot stat 'qtmidi-v0.1-*': No such file or directory

Comment 8 greg.hellings 2017-11-17 00:55:16 UTC
I'm not seeing the same issue. I haven't changed anything except to rebuild the SRPM in the fc28 namespace.

Comment 9 greg.hellings 2018-03-14 03:23:04 UTC
Here's a rebuild against Rawhide in the Fedora 29 cycle. Anyone want to finish out this review for me?


Comment 11 Package Review 2020-07-10 00:55:50 UTC
This is an automatic check from review-stats script.

This review request ticket hasn't been updated for some time. We're sorry
it is taking so long. If you're still interested in packaging this software
into Fedora repositories, please respond to this comment clearing the

You may want to update the specfile and the src.rpm to the latest version
available and to propose a review swap on Fedora devel mailing list to increase
chances to have your package reviewed. If this is your first package and you
need a sponsor, you may want to post some informal reviews. Read more at

Without any reply, this request will shortly be considered abandoned
and will be closed.
Thank you for your patience.

Comment 12 Package Review 2020-08-10 00:56:44 UTC
This is an automatic action taken by review-stats script.

The ticket submitter failed to clear the NEEDINFO flag in a month.
As per
we consider this ticket as DEADREVIEW and proceed to close it.

Note You need to log in before you can comment on or make changes to this bug.