Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1555081 - python2-2.7.14-14 breaks fedpkg build (_ssl.so: undefined symbol: Py_MAX)
Summary: python2-2.7.14-14 breaks fedpkg build (_ssl.so: undefined symbol: Py_MAX)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-13 23:37 UTC by Kevin Fenzi
Modified: 2018-03-30 12:56 UTC (History)
9 users (show)

Fixed In Version: python2-2.7.14-15.fc29 python2-2.7.14-7.fc26 python2-2.7.14-10.fc27 python2-2.7.14-15.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-20 17:34:00 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1554760 0 unspecified CLOSED Don't send IP address as SNI TLS extension 2022-05-16 11:32:56 UTC

Internal Links: 1554760

Description Kevin Fenzi 2018-03-13 23:37:37 UTC
When I update to python2-2.7.14-14.fc29 fedpkg build fails with: 

✗ fedpkg build --nowait 
Kerberos authentication fails: OpenSSL library did not load
Could not execute build: Could not login to https://koji.fedoraproject.org/kojihub

koji works fine (because it's python3). Downgrading to -13 of python2 gets it working again too.

Comment 1 Miro Hrončok 2018-03-14 08:54:23 UTC
Simpler reproducer:

 # dnf install python2-pyOpenSSL
 >>> import OpenSSL

Or even just:

 >>> import _ssl

Comment 2 Miro Hrončok 2018-03-14 09:09:59 UTC
Consulted Christian Heimes, apparently this is a known thing, fixed upstream. Adding the patch. https://github.com/python/cpython/pull/5878

Comment 3 Kevin Fenzi 2018-03-14 16:01:30 UTC
Thanks for the very quick fix here. :)

Comment 4 Fedora Update System 2018-03-14 16:22:28 UTC
python2-2.7.14-10.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a9d2b42ad4

Comment 5 Fedora Update System 2018-03-14 16:25:51 UTC
python2-2.7.14-7.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-031d0ddaa3

Comment 6 Fedora Update System 2018-03-14 20:07:27 UTC
python2-2.7.14-7.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-031d0ddaa3

Comment 7 Fedora Update System 2018-03-14 20:44:56 UTC
python2-2.7.14-10.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a9d2b42ad4

Comment 8 Fedora Update System 2018-03-15 10:06:22 UTC
python2-2.7.14-15.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a84c91e538

Comment 9 Fedora Update System 2018-03-15 13:32:43 UTC
python2-2.7.14-15.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a84c91e538

Comment 10 Fedora Update System 2018-03-20 17:34:00 UTC
python2-2.7.14-7.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-03-20 18:20:34 UTC
python2-2.7.14-10.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2018-03-30 12:56:30 UTC
python2-2.7.14-15.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.