Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1842132 - python-nipy fails to build from source due to ModuleNotFoundError (No module named 'numpy.testing.decorators')
Summary: python-nipy fails to build from source due to ModuleNotFoundError (No module ...
Keywords:
Status: CLOSED DUPLICATE of bug 1800845
Alias: None
Product: Fedora
Classification: Fedora
Component: python-nipy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1800845
Blocks: PYTHON39 F33FTBFS F33FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-05-30 17:33 UTC by Igor Raits
Modified: 2020-06-11 09:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-11 09:57:48 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Igor Raits 2020-05-30 17:33:56 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain).

Your package (python-nipy) Fails To Install in Fedora 33:

can't install python3-nipy:
  - nothing provides python(abi) = 3.8 needed by python3-nipy-0.4.2-5.fc32.x86_64
  
If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/rawhide-gating/multi-builds/

Thanks!

Comment 1 Tomáš Hrnčiar 2020-06-11 09:36:10 UTC
python-nipy fails to build from source due to ModuleNotFoundError (No module named 'numpy.testing.decorators')

Failure: ModuleNotFoundError (No module named 'numpy.testing.decorators') ... ERROR
======================================================================
ERROR: Failure: ModuleNotFoundError (No module named 'numpy.testing.decorators')
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/nose/failure.py", line 39, in runTest
    raise self.exc_val.with_traceback(self.tb)
  File "/usr/lib/python3.9/site-packages/nose/loader.py", line 416, in loadTestsFromName
    module = self.importer.importFromPath(
  File "/usr/lib/python3.9/site-packages/nose/importer.py", line 47, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib/python3.9/site-packages/nose/importer.py", line 94, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/usr/lib64/python3.9/imp.py", line 244, in load_module
    return load_package(name, filename)
  File "/usr/lib64/python3.9/imp.py", line 216, in load_package
    return _load(spec)
  File "<frozen importlib._bootstrap>", line 711, in _load
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 790, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/builddir/build/BUILD/nipy-0.4.2/build/lib.linux-x86_64-3.9/nipy/__init__.py", line 12, in <module>
    from nipy.testing import Tester
  File "/builddir/build/BUILD/nipy-0.4.2/build/lib.linux-x86_64-3.9/nipy/testing/__init__.py", line 44, in <module>
    from . import decorators as dec
  File "/builddir/build/BUILD/nipy-0.4.2/build/lib.linux-x86_64-3.9/nipy/testing/decorators.py", line 11, in <module>
    from numpy.testing.decorators import *
ModuleNotFoundError: No module named 'numpy.testing.decorators'
----------------------------------------------------------------------
Ran 1 test in 0.102s
FAILED (errors=1)
error: Bad exit status from /var/tmp/rpm-tmp.34qg4I (%check)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.34qg4I (%check)
Child return code was: 1
EXCEPTION: [Error()]
Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/mockbuild/trace_decorator.py", line 93, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.7/site-packages/mockbuild/util.py", line 755, in do_with_status
    raise exception.Error("Command failed: \n # %s\n%s" % (command, output), child.returncode)
mockbuild.exception.Error: Command failed: 
 # bash --login -c /usr/bin/rpmbuild -bb --target x86_64 --nodeps /builddir/build/SPECS/python-nipy.spec

Comment 2 Ankur Sinha (FranciscoD) 2020-06-11 09:57:48 UTC

*** This bug has been marked as a duplicate of bug 1800845 ***


Note You need to log in before you can comment on or make changes to this bug.