Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 579131 - [abrt] crash in psi-0.14-1.fc13: Process /usr/bin/psi was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in psi-0.14-1.fc13: Process /usr/bin/psi was killed by signal 6 ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: psi
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:74dc57bf9497498d322da8ed82c...
: 579673 (view as bug list)
Depends On:
Blocks: DebugInfo
TreeView+ depends on / blocked
 
Reported: 2010-04-02 19:12 UTC by Raphael Groner
Modified: 2010-04-20 13:14 UTC (History)
6 users (show)

Fixed In Version: psi-0.14-3.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-20 13:14:23 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2010-04-02 19:12 UTC, Raphael Groner
no flags Details
Disable Qt debugging macros (deleted)
2010-04-04 13:31 UTC, Sergey Fionov
no flags Details | Diff

Description Raphael Groner 2010-04-02 19:12:44 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: psi
comment: psi crashes
component: psi
executable: /usr/bin/psi
kernel: 2.6.33.1-19.fc13.x86_64
package: psi-0.14-1.fc13
rating: 4
reason: Process /usr/bin/psi was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. install psi-icons
2. start psi
3. select in menu options/appearance/icons

Comment 1 Raphael Groner 2010-04-02 19:12:47 UTC
Created attachment 404228 [details]
File: backtrace

Comment 2 Raphael Groner 2010-04-03 17:23:56 UTC
It seems to be related to a failing assert statement. 

Please rebuild the package without debug support at all.

Comment 3 Sergey Fionov 2010-04-03 17:34:56 UTC
Seems that there are wrong configure options.

"--debug --no-separate-debug-info" flags disable QT_NO_DEBUG macro, that makes
Q_ASSERTs fatal. It is incorrect behaviour for package that is not to be used
to develop Psi. When Qt debug is not enabled, all asserts are ignored.

I think that "release" version should be built, with debug compiler flags
enabled for debuginfo packages (and qt debug flags disabled).

Comment 4 Raphael Groner 2010-04-03 19:03:49 UTC
Workaround:
Remove those three files from /usr/share/psi/iconsets:
  emoticons/gadu_gadu.jisp, roster/kitty.jisp and roster/dudes32.jisp

Comment 5 Sergey Fionov 2010-04-04 13:31:05 UTC
Created attachment 404397 [details]
Disable Qt debugging macros

The proposed patch adds QT_NO_DEBUG define to disable Qt debugging macros. Due to "debug" config option debuginfo will not be lost.

With this patch Psi doesn't abort on incorrect iconsets as in "release" build.

Comment 6 Fedora Update System 2010-04-05 05:42:14 UTC
psi-0.14-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/psi-0.14-2.fc13

Comment 7 Raphael Groner 2010-04-05 14:41:23 UTC
(In reply to comment #6)
> psi-0.14-2.fc13 has been submitted as an update for Fedora 13.
> http://admin.fedoraproject.org/updates/psi-0.14-2.fc13    

Bugfix confirmed. Above described behaviour (crash) does not occur any more.
Thanks for the quick patch!

Comment 8 Sven Lankes 2010-04-06 08:45:43 UTC
*** Bug 579673 has been marked as a duplicate of this bug. ***

Comment 9 David Kovalsky 2010-04-06 09:06:48 UTC
Is there going to be an F12 update too? My F12 bug 579673 has been closed as a duplicate of this one.

Comment 10 Fedora Update System 2010-04-06 19:56:47 UTC
psi-0.14-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update psi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/psi-0.14-2.fc13

Comment 11 Sven Lankes 2010-04-06 20:14:14 UTC
(In reply to comment #9)

> Is there going to be an F12 update too? My F12 bug 579673 has been closed as a
> duplicate of this one.    

Sorry. I should have added a note when closing your bug. An update is also available for F12: https://admin.fedoraproject.org/updates/psi-0.14-2.fc12

Comment 12 David Kovalsky 2010-04-07 08:19:57 UTC
Thanks Sven! :)

Comment 13 Raphael Groner 2010-04-07 19:39:38 UTC
Who is responsible for closing this bug? 

Can I (as the reporter) close it?
I have verified the patched package is now available in repository.

Comment 14 Aurelien Bompard 2010-04-07 19:47:11 UTC
The bug will be closed when the package is moved to the stable repo. No need to do it yourself, but thanks anyway :)

Comment 15 Ville Skyttä 2010-04-07 19:50:52 UTC
This change has made -debuginfo probably useless, I suppose (based on quick
look at the build log and -debuginfo no longer having sources) because the
build now strips objects before rpmbuild has had a chance to do it.  See
blocker bug for more info.

Comment 16 Raphael Groner 2010-04-07 19:55:48 UTC
(In reply to comment #13)

I am able to test only with rawhide. Therefore and due to the duplication of bug (comments #8 to #11), I am not sure about Version and Platform. Bug seems to exist since F11. And besides x86_64 also for i686?

Comment 17 Aurelien Bompard 2010-04-07 19:58:03 UTC
> This change has made -debuginfo probably useless

OK, any way to keep the objects unstripped and not crash on failed assertions ?

Comment 18 Sergey Fionov 2010-04-07 20:14:54 UTC
I suggest to add QT_NO_DEBUG define which disables qt debugging macros, instead of switching off debug. See my comment #5 and patch.

Comment 19 Ville Skyttä 2010-04-07 20:17:23 UTC
Based on comments 3, 4, and 18 I gather stripping is not the issue (that would be
very rare), it's the other things that the --debug and --no-separate-debug-info
do.  No matter whether those are left in or out, it should be ensured that the upstream build respects $RPM_OPT_FLAGS and does not attempt any stripping itself, by patching if necessary.

Comment 20 Raphael Groner 2010-04-07 22:04:23 UTC
Updated package from repository is okay for me.

Name       : psi
Architektur : x86_64
Version    : 0.14
Ausgabe    : 2.fc13
Grösse     : 6.5 M
Repo       : installed
Aus repo    : updates-testing

Comment 21 Fedora Update System 2010-04-08 05:42:24 UTC
psi-0.14-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/psi-0.14-3.fc13

Comment 22 Fedora Update System 2010-04-09 04:15:12 UTC
psi-0.14-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update psi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/psi-0.14-3.fc13

Comment 23 Fedora Update System 2010-04-20 13:14:17 UTC
psi-0.14-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.